<!DOCTYPE html><html
lang="en"><head><meta
charset="utf-8"><meta
http-equiv="X-UA-Compatible" content="IE=edge"><meta
name="viewport" content="width=device-width, initial-scale=1"><title>Katt Williams | Stand-Up Comedy Database | Dead-Frog - A Comedy Blog</title><meta
name="description" content="Profile of stand-up comedian Katt Williams including complete works, video, biography, jokes, reviews and tour schedule." /><meta
property="og:title" content="Katt Williams | Stand-Up Comedy Database | Dead-Frog - A Comedy Blog"/><meta
property="og:type" content="actor" /><meta
property="og:url" content="http://www.dead-frog.com/comedians/comic/katt-williams" /><meta
property="og:image" content="http://media.dead-frog.com/comics/katt_williams.jpg?mtime=1491644238" /><meta
property="og:locale" content="en_US"><meta
property="og:description" content="Profile of stand-up comedian Katt Williams including complete works, video, biography, jokes, reviews and tour schedule."><meta property="og:site_name" content="Dead-Frog - A Comedy Blog" />
<meta property="fb:admins" content="649961018" />
<meta property="fb:app_id" content="152881194733416" /><meta
name="twitter:card" content="summary" /><meta
name="twitter:site" content="@deadfrog" /><meta
name="twitter:title" content="Katt Williams | Stand-Up Comedy Database | Dead-Frog - A Comedy Blog" /><meta
name="twitter:description" content="Profile of stand-up comedian Katt Williams including complete works, video, biography, jokes, reviews and tour schedule." /><meta
name="twitter:image" content="http://media.dead-frog.com/comics/katt_williams.jpg?mtime=1491644238" /> <script>(function(d){var config={kitId:'rco3wrc',scriptTimeout:3000,async:true},h=d.documentElement,t=setTimeout(function(){h.className=h.className.replace(/\bwf-loading\b/g,"")+" wf-inactive";},config.scriptTimeout),tk=d.createElement("script"),f=false,s=d.getElementsByTagName("script")[0],a;h.className+=" wf-loading";tk.src='https://use.typekit.net/'+config.kitId+'.js';tk.async=true;tk.onload=tk.onreadystatechange=function(){a=this.readyState;if(f||a&&a!="complete"&&a!="loaded")return;f=true;clearTimeout(t);try{Typekit.load(config)}catch(e){}};s.parentNode.insertBefore(tk,s)})(document);</script> <link
rel="apple-touch-icon" sizes="180x180" href="/apple-touch-icon.png?v=7knYE34lqN"><link
rel="icon" type="image/png" href="/favicon-32x32.png?v=7knYE34lqN" sizes="32x32"><link
rel="icon" type="image/png" href="/favicon-16x16.png?v=7knYE34lqN" sizes="16x16"><link
rel="manifest" href="/manifest.json?v=7knYE34lqN"><link
rel="mask-icon" href="/safari-pinned-tab.svg?v=7knYE34lqN" color="#c41400"><link
rel="shortcut icon" href="/favicon.ico?v=7knYE34lqN"><meta
name="theme-color" content="#ffffff"><link
rel="stylesheet" href="https://maxcdn.bootstrapcdn.com/bootstrap/3.3.7/css/bootstrap.min.css" integrity="sha384-BVYiiSIFeK1dGmJRAkycuHAHRg32OmUcww7on3RYdg4Va+PmSTsz/K68vbdEjh4u" crossorigin="anonymous"> <script src="https://use.fontawesome.com/54005dc295.js"></script> <link
rel="stylesheet" type="text/css" media="all" href="http://www.dead-frog.com/minicache/a0334d0fb0ab6d0ff255447bd39d67f0c95a2570.1491720825.css" />
<!--[if lt IE 9]> <script src="https://oss.maxcdn.com/html5shiv/3.7.2/html5shiv.min.js"></script> <script src="https://oss.maxcdn.com/respond/1.4.2/respond.min.js"></script> <![endif]--><link
rel="alternate" type="application/rss+xml" title="RSS feed for Dead-Frog Blog" href="http://feeds.feedburner.com/dead-frog" /><link
rel="alternate" type="application/rss+xml" title="RSS feed for Dead-Frog Stand-Up Comic Database" href="http://feeds.feedburner.com/standupcomedy" /> <script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script> <script>var googletag=googletag||{};googletag.cmd=googletag.cmd||[];</script> <script>var gptAdSlots=[];googletag.cmd.push(function(){var mapmobile=googletag.sizeMapping().addSize([0,0],[]).addSize([320,400],[320,50]).addSize([753,500],[]).build();var maptop=googletag.sizeMapping().addSize([0,0],[]).addSize([753,500],[728,90]).build();var mapbox=googletag.sizeMapping().addSize([0,0],[]).addSize([753,500],[300,250]).build();gptAdSlots[0]=googletag.defineSlot('/74561012/Dead-Frog_Mobile_Leader',[320,50],'div-gpt-ad-1491386249373-0').defineSizeMapping(mapmobile).setCollapseEmptyDiv(true).addService(googletag.pubads());gptAdSlots[1]=googletag.defineSlot('/74561012/Dead-Frog_Box',[300,250],'div-gpt-ad-1491386249373-1').defineSizeMapping(mapbox).addService(googletag.pubads());gptAdSlots[2]=googletag.defineSlot('/74561012/Dead-Frog_Leader',[728,90],'div-gpt-ad-1491386249373-2').defineSizeMapping(maptop).setCollapseEmptyDiv(true).addService(googletag.pubads());googletag.pubads().setCentering(true);googletag.enableServices();});</script> <link
rel="canonical" href="http://www.dead-frog.com/comedians/comic/katt-williams" /><script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-576170-1', {'siteSpeedSampleRate': 100});
  ga('send', 'pageview');

</script></head><body ><div
id="site_top" class="hidden-xs"><div
class="container-fluid"><div
class="row"><div
id="logo" class="col-sm-8">
<a
href="/" title="Dead-Frog Home Page">
<img
src="http://media.dead-frog.com/site/new_logo.png" alt="Dead-Frog - A Comedy Blog" width="520" height="75" border="0" />
</a></div><div
class="col-sm-4"><div
class="new_members"><img
src="http://media.dead-frog.com/site/dead_frog_icon_grey.jpg" alt="default dead-frog avatar" height="50" width="50" class="top_avatar"/><div
class="memberinfo"><h4>Member Functions</h4><ul><li><a
href="http://www.dead-frog.com/audience/login">Log-In</a></li><li><a
href="http://www.dead-frog.com/audience/register">Register</a></li><li><a
href="http://www.dead-frog.com/audience/forgot_password">Forgot Password</a>?</li><ul></div></div></div></div><div
class="topads">
<!-- /74561012/Dead-Frog_Leader -->
<div id='div-gpt-ad-1491386249373-2' style='height:90px; width:728px;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1491386249373-2'); });
</script>
</div></div></div></div><nav
class="navbar navbar-inverse mynavbar"><div
class="navbar-container container-fluid"><div
class="navbar-header">
<button
type="button" class="navbar-toggle collapsed" data-toggle="collapse" data-target="#bs-example-navbar-collapse-1">
<span
class="sr-only">Toggle navigation</span>
<span
class="icon-bar"></span>
<span
class="icon-bar"></span>
<span
class="icon-bar"></span>
</button>
<a
class="navbar-brand visible-xs-block" href="http://www.dead-frog.com">
<img
alt="Dead-Frog - A Comedy Blog" src="http://media.dead-frog.com/site/mobile_logo.png"  width="200" height="39">
</a></div><div
class="collapse navbar-collapse" id="bs-example-navbar-collapse-1"><ul
class="nav navbar-nav"><li >
<a
href="http://www.dead-frog.com/blog" title="Comedy Blog and Comedy News">blog</a></li><li
class="dropdown active">
<a
href="http://www.dead-frog.com/comedians" class="dropdown-toggle" data-toggle="dropdown" role="button" aria-haspopup="true" aria-expanded="false" title="Stand-Up Comedy Database">comedians <span
class="caret"></span></a><ul
class="dropdown-menu"><li><a
href="http://www.dead-frog.com/comedians/funniest">Funniest</a></li><li><a
href="http://www.dead-frog.com/comedians/favorite">Favorite</a></li><li
role="separator" class="divider"></li><li><a
href="http://www.dead-frog.com/comedians/greatest-living">Greatest Living</a></li><li><a
href="http://www.dead-frog.com/comedians/best">Best Comedians Ever</a></li><li><a
href="http://www.dead-frog.com/comedians/best-material">Best Joke Writers</a></li><li><a
href="http://www.dead-frog.com/comedians/best-delivery">Best Joke Tellers</a></li><li
role="separator" class="divider"></li><li><a
href="http://www.dead-frog.com/comedians/list">All Comedians</a></li></ul></li><li >
<a
href="http://www.dead-frog.com/live-comedy" title="Live Comedy">live comedy</a></li><li >
<a
href="http://www.dead-frog.com/comedy-clubs" title="Comedy Clubs">comedy clubs</a></li><li >
<a
href="http://www.dead-frog.com/comedians/whos-funnier" title="Who&rsquo;s Funnier">who&rsquo;s funnier</a></li><li >
<a
href="http://www.dead-frog.com/charts" title="iTunes Top 100 Comedy Albums">charts</a></li><li >
<a
href="http://www.dead-frog.com/site/about" title="About Dead-Frog and Todd Jackson">about</a></li></ul><form
id="new_top_search" class="navbar-form navbar-right hidden-xs hidden-sm" method="post" action="http://www.dead-frog.com/"  ><div
class='hiddenFields'>
<input
type="hidden" name="ACT" value="25032105" />
<input
type="hidden" name="RES" value="200" />
<input
type="hidden" name="meta" value="mzWR5rp/vLEnoGhgsDwNhp3UvapFFpivsFH0CTLWqnuEiQ5/873Q9eUL8MccJU7/EaFDhJE3oLy3Y6wipxxXPTdR8stGi589ow9oHliV1E1Rl1cOagHqJkVspU8k9r9mr5guUsTbYeEj2Ztrw3lCrKhVzizeqvVUkUns+2WfLOBVCYLppmXV9xDmzzOE1Q32asD+DtGTQmrpJKWSUg25HF1fBl/L559DQoQbICwYkgmDd+131TrsAn5XQLVOC076AF+h5oCWJeQQopYj+1i6s7fdkPrpv27QbmE2660T+aIKHYyjNgxIiXYw1seVbMsoVZ8eaKtjl0ro2QK+TWZwDHjQQMgNmdgpuLDDoBhRJLctfRWdIECzCTHiIy/ft8eA" />
<input
type="hidden" name="site_id" value="1" />
<input
type="hidden" name="csrf_token" value="6ea5922661603fdfa6c6b234eef29a0942027ee8" /></div><div
class="form-group">
<input
type="text" name="keywords" id="keywords" value="" class="form-control" placeholder="Search" /></div>
<button
type="submit" class="btn btn-custom"/>
<span
class="glyphicon glyphicon-search" aria-hidden="true"></span>
</button></form></div></div>
</nav><div
class="container-fluid main_container"><div
class="visible-xs-block row mobile-ad-bg"><div
class="mobile-ad"><div
id='div-gpt-ad-1491386249373-0' style='height:50px; width:320px;'> <script>googletag.cmd.push(function(){googletag.display('div-gpt-ad-1491386249373-0');});</script> </div></div></div><div
class="row"><div
class="col-xs-12"></div><div
class="col-xs-12 col-md-8 center-stage" >
<header
class="comic_innernav"><div
class="row"><div
class="col-xs-12 col-sm-7">
<a
href="http://www.dead-frog.com/comedians"><h2>Stand-Up Comedy Database</h2></a></div><div
class="innernav_section col-xs-12 col-sm-5"><form
id="comic_innernav_search" method="post" action="http://www.dead-frog.com/"  ><div
class='hiddenFields'>
<input
type="hidden" name="ACT" value="25032105" />
<input
type="hidden" name="RES" value="" />
<input
type="hidden" name="meta" value="mzWR5rp/vLEnoGhgsDwNhp3UvapFFpivsFH0CTLWqns6syJdumj0qeDaM0T0+5R0PBBWSdnSGhA471vKA9B8daH45kQp5gt6SAWaUfoGeU8Vjzozj4XFRI7+gSZFlfIOEWa/grBH/xCryb60/N8zMepUg62q3XTjSP9NkbPfSBHzc4Lj0tEAAQAdC6JpCwbSl78fl4b4sTShcHyodNy1j1HLuMzLf3FtUwUNsBXdJiW83GQkoSlDAgKdsaeGlJUThAqnLX2QmqDPD1bXUG8y7OEJWyn7fIUjXbOyhBt+FN8rC24ygllhTl9Pj2SUnrUx8DSGi/vbt0FQVybElfhhjgB8a0gP+HRY4z/1AkMNQUWCLUzH/JxOK2sqv+EEXS4W" />
<input
type="hidden" name="site_id" value="1" />
<input
type="hidden" name="csrf_token" value="6ea5922661603fdfa6c6b234eef29a0942027ee8" /></div><div
class="input-group input-group-sm">
<input
type="text" name="keywords" id="comickeywords" placeholder="Find a Comic" value="" class="form-control" size="18" maxlength="50" />
<span
class="input-group-btn">
<button
class="btn btn-default btn-custom" type="submit"/><span
class="glyphicon glyphicon-search" aria-hidden="true"></span></button>
</span></div></form></div></div>
</header><div
class="row profile_head_row"><div
class="col-xs-12"><div
class="media main_profile_top"><div
class="media-left">
<img
src="http://media.dead-frog.com/comics/katt_williams.jpg?mtime=1491644238" width="113" height="150" class="main_image" alt="Stand-Up Comedian Katt Williams"/></div><div
class="media-body"><h1 id="page_head">Katt Williams</h1><div
class="vitals">
<strong>Born:</strong> September 2, 1975<br/>
<strong>Blue Meter:</strong> Dirty<br/></div></div></div></div></div><div
class="row"><div
class="col-xs-12 no-gutter"><ul
id="comic_profile_nav" class="nav nav-tabs"><li
role="presentation" class="active"><a
href="#">Main</a></li><li
role="presentation"><a
href="/comedians/jokes/katt-williams">Jokes</a></li><li
role="presentation"><a
href="http://www.dead-frog.com/comedians/reviews/katt-williams">Reviews</a></li><li
role="presentation"><a
href="http://www.dead-frog.com/comedians/video/katt-williams">Video</a></li><li
role="presentation"><a
href="http://www.dead-frog.com/comedians/tour-dates/katt-williams"><span
class="hidden-xs">Tour Dates</span><span
class="visible-xs-block">Live</span></a></li></ul></div></div><div
class="comic_content"><div
class="row"><div
class="col-xs-12 col-sm-5"><div
class="favorites"><div
class="favenum fave_1861 faveprofile" >
<span>29</span>&nbsp;<i
class="fa fa-heart" aria-hidden="true"></i></div><div
class="fave_comic"><p>Like this comedian?<br/><a
href="http://www.dead-frog.com/audience/login">Log-In</a> or <a
href="http://www.dead-frog.com/audience/register">Register</a> to mark it!</p></div></div></div><div
class="col-xs-12 col-sm-7"><div
class="wf_box"><h3 class="wf_head"><a
href="/comedians/whos-funnier">Who's Funnier</a></h3>
<span
class="wf_percentage">46.1%</span>
<span
class="wf_record">
<strong>Won:</strong> 1694<br/><strong>Lost:</strong> 1985
</span></div></div></div><div
id="shows"><h2 class="secondary_head">Next Tour Date</h2>
<div
class="event_row row"><div
class="col_showdate col-xs-12 col-sm-2"><div
class="col_showdate_container hidden-xs">
<span
class="showdate_month">Apr</span>
<span
class="showdate_day">14</span>
<span
class="showdate_weekday">Fri</span></div><div
class="day_head visible-xs-block">Friday | April 14</div></div><div
class="col_showtime col-xs-2">
8:00 PM</div><div
class="col_showdetails col-xs-7 col-sm-6"><h5 class="show_name">Katt Williams: Great America</h5><div
class="col_venue">
<strong><span
class="glyphicon glyphicon-map-marker" aria-hidden="true"></span>Nashville Municipal Auditorium</strong> Nashville, TN</div></div><div
class="col-xs-3 col-sm-2 col_showticket">
<a
href="/live_comedy/event/271130" class="btn btn-sm btn-block btn-custom">Buy<span
class="hidden-xs"> Tickets</span></a></div></div><p
class="text-center"><a
href="http://www.dead-frog.com/comedians/tour-dates/katt-williams">See all Katt Williams's tour dates</a></p></div><div
class="works"><h2 class="secondary_head">Works</h2><a
href="#records"><h3 class="work_head">Records</h3></a><table
class="table table-striped"><tr><td
class="date">2015</td><td
class="title"><strong>Priceless</strong></td><td
class="buylinks">
<strong
class="hidden-xs">Buy </strong>
<a
href="http://www.amazon.com/gp/product/B00TV0I3BI?ie=UTF8&amp;tag=comedydb-20&amp;linkCode=as2&amp;camp=1789&amp;creative=9325&amp;creativeASIN=B00TV0I3BI" rel="nofollow">Amazon</a>
<span
class="hidden-xs"> | </span>
<a
href="https://itunes.apple.com/us/album/priceless/id969554268?uo=4&partnerId=11&at=10l8IA&app=itunes" rel="nofollow">iTunes</a></td></tr><tr><td
class="date">2013</td><td
class="title"><strong>Live</strong></td><td
class="buylinks">
<strong
class="hidden-xs">Buy </strong>
<a
href="http://www.amazon.com/gp/product/B00F8QUQ1O?ie=UTF8&amp;tag=comedydb-20&amp;linkCode=as2&amp;camp=1789&amp;creative=9325&amp;creativeASIN=B00F8QUQ1O" rel="nofollow">Amazon</a>
<span
class="hidden-xs"> | </span>
<a
href="https://itunes.apple.com/us/album/live/id708490496?uo=4&partnerId=11&at=10l8IA&app=itunes" rel="nofollow">iTunes</a></td></tr><tr><td
class="date">2012</td><td
class="title"><strong>Kattpacalypse</strong></td><td
class="buylinks">
<strong
class="hidden-xs">Buy </strong>
<a
href="http://www.amazon.com/gp/product/B0094N31W8?ie=UTF8&amp;tag=comedydb-20&amp;linkCode=as2&amp;camp=1789&amp;creative=9325&amp;creativeASIN=B0094N31W8" rel="nofollow">Amazon</a>
<span
class="hidden-xs"> | </span>
<a
href="https://geo.itunes.apple.com/us/album/kattpacalypse/id557942910?uo=4&at=10l8IA&app=itunes" rel="nofollow">iTunes</a></td></tr><tr><td
class="date">2009</td><td
class="title"><strong>Katt Williams: Pimpadelic</strong></td><td
class="buylinks">
<strong
class="hidden-xs">Buy </strong>
<a
href="http://www.amazon.com/gp/product/B00318P0JO?ie=UTF8&amp;tag=comedydb-20&amp;linkCode=as2&amp;camp=1789&amp;creative=9325&amp;creativeASIN=B00318P0JO" rel="nofollow">Amazon</a>
<span
class="hidden-xs"> | </span>
<a
href="https://geo.itunes.apple.com/us/album/pimpadelic/id517592638?uo=4&at=10l8IA&app=itunes" rel="nofollow">iTunes</a></td></tr><tr><td
class="date">2009</td><td
class="title"><strong>Katt Williams: It's Pimpin' Pimpin'</strong></td><td
class="buylinks">
<strong
class="hidden-xs">Buy </strong>
<a
href="http://www.amazon.com/gp/product/B0129LIQE4?ie=UTF8&amp;tag=comedydb-20&amp;linkCode=as2&amp;camp=1789&amp;creative=9325&amp;creativeASIN=B0129LIQE4" rel="nofollow">Amazon</a>
<span
class="hidden-xs"> | </span>
<a
href="https://itunes.apple.com/us/album/katt-williams-its-pimpin-pimpin/id1021782897?uo=4&partnerId=11&at=10l8IA&app=itunes" rel="nofollow">iTunes</a></td></tr><tr><td
class="date">2007</td><td
class="title"><strong>Katt Williams: American Hustle</strong></td><td
class="buylinks">
<strong
class="hidden-xs">Buy </strong>
<a
href="http://www.amazon.com/gp/product/B012PXTRDA?ie=UTF8&amp;tag=comedydb-20&amp;linkCode=as2&amp;camp=1789&amp;creative=9325&amp;creativeASIN=B012PXTRDA" rel="nofollow">Amazon</a>
<span
class="hidden-xs"> | </span>
<a
href="https://itunes.apple.com/us/album/katt-williams-american-hustle/id1023497489?uo=4&partnerId=11&at=10l8IA&app=itunes" rel="nofollow">iTunes</a></td></tr><tr><td
class="date">2006</td><td
class="title"><strong>Live: Let a Playa Play</strong></td><td
class="buylinks">
<strong
class="hidden-xs">Buy </strong>
<a
href="http://www.amazon.com/gp/product/B000JJRWFI?ie=UTF8&amp;tag=comedydb-20&amp;linkCode=as2&amp;camp=1789&amp;creative=9325&amp;creativeASIN=B000JJRWFI" rel="nofollow">Amazon</a></td></tr><tr><td
class="date">2006</td><td
class="title"><strong>Katt Williams: The Pimp Chronicles Pt. 1</strong></td><td
class="buylinks">
<strong
class="hidden-xs">Buy </strong>
<a
href="http://www.amazon.com/gp/product/B011QC5KLY?ie=UTF8&amp;tag=comedydb-20&amp;linkCode=as2&amp;camp=1789&amp;creative=9325&amp;creativeASIN=B011QC5KLY" rel="nofollow">Amazon</a>
<span
class="hidden-xs"> | </span>
<a
href="https://itunes.apple.com/us/album/katt-williams-pimp-chronicles/id1019721846?uo=4&partnerId=11&at=10l8IA&app=itunes" rel="nofollow">iTunes</a></td></tr></table><a
href="#specials"><h3 class="work_head">Specials <span>(and other video)</span></h3></a><table
class="table table-striped"><tr><td
class="date">2014</td><td
class="title"><strong>Katt Williams: Priceless: Afterlife</strong></td><td
class="buylinks">
<strong
class="hidden-xs">Buy </strong>
<a
href="http://www.amazon.com/gp/product/B00QJ9N1N4?ie=UTF8&amp;tag=comedydb-20&amp;linkCode=as2&amp;camp=1789&amp;creative=9325&amp;creativeASIN=B00QJ9N1N4" rel="nofollow">Amazon</a>
<span
class="hidden-xs"> | </span>
<a
href="https://geo.itunes.apple.com/us/movie/katt-williams-priceless-afterlife/id967028877?at=10l8IA&mt=6" rel="nofollow">iTunes</a></td></tr><tr><td
class="date">2012</td><td
class="title"><strong>Katt Williams: Kattpacalypse</strong></td><td
class="buylinks">
<strong
class="hidden-xs">Buy </strong>
<a
href="http://www.amazon.com/gp/product/B008FXLZ6W?ie=UTF8&amp;tag=comedydb-20&amp;linkCode=as2&amp;camp=1789&amp;creative=9325&amp;creativeASIN=B008FXLZ6W" rel="nofollow">Amazon</a>
<span
class="hidden-xs"> | </span>
<a
href="https://geo.itunes.apple.com/us/movie/katt-williams-kattpacalypse/id554719560?uo=4&at=10l8IA" rel="nofollow">iTunes</a></td></tr><tr><td
class="date">2010</td><td
class="title"><strong>Chocolate Sundaes Comedy Show: Live On Sunset Strip!</strong></td><td
class="buylinks">
<strong
class="hidden-xs">Buy </strong>
<a
href="http://www.amazon.com/gp/product/B004025P9K?ie=UTF8&amp;tag=comedydb-20&amp;linkCode=as2&amp;camp=1789&amp;creative=9325&amp;creativeASIN=B004025P9K" rel="nofollow">Amazon</a>
<span
class="hidden-xs"> | </span>
<a
href="https://geo.itunes.apple.com/us/movie/chocolate-sundaes-presents/id387779682?uo=4&at=10l8IA" rel="nofollow">iTunes</a></td></tr><tr><td
class="date">2010</td><td
class="title"><strong>Katt Williams: 9 Lives</strong></td><td
class="buylinks">
<strong
class="hidden-xs">Buy </strong>
<a
href="http://www.amazon.com/gp/product/B004AD9MGG?ie=UTF8&amp;tag=comedydb-20&amp;linkCode=as2&amp;camp=1789&amp;creative=9325&amp;creativeASIN=B004AD9MGG" rel="nofollow">Amazon</a>
<span
class="hidden-xs"> | </span>
<a
href="https://geo.itunes.apple.com/us/movie/katt-williams-9-lives/id389966266?uo=4&at=10l8IA" rel="nofollow">iTunes</a></td></tr><tr><td
class="date">2009</td><td
class="title"><strong>Katt Williams: Pimpadelic</strong></td><td
class="buylinks">
<strong
class="hidden-xs">Buy </strong>
<a
href="http://www.amazon.com/gp/product/B002FE5XS8?ie=UTF8&amp;tag=comedydb-20&amp;linkCode=as2&amp;camp=1789&amp;creative=9325&amp;creativeASIN=B002FE5XS8" rel="nofollow">Amazon</a>
<span
class="hidden-xs"> | </span>
<a
href="https://geo.itunes.apple.com/us/movie/katt-williams-pimpadelic/id331478700?uo=4&at=10l8IA" rel="nofollow">iTunes</a></td></tr><tr><td
class="date">2009</td><td
class="title"><strong>Katt Williams: The Pimp Legacy</strong></td><td
class="buylinks">
<strong
class="hidden-xs">Buy </strong>
<a
href="http://www.amazon.com/gp/product/B001PNAV9G?ie=UTF8&amp;tag=comedydb-20&amp;linkCode=as2&amp;camp=1789&amp;creative=9325&amp;creativeASIN=B001PNAV9G" rel="nofollow">Amazon</a></td></tr><tr><td
class="date">2008</td><td
class="title"><strong>Katt Williams: It's Pimpin' Pimpin'</strong></td><td
class="buylinks">
<strong
class="hidden-xs">Buy </strong>
<a
href="http://www.amazon.com/gp/product/B001D2WUDO?ie=UTF8&amp;tag=comedydb-20&amp;linkCode=as2&amp;camp=1789&amp;creative=9325&amp;creativeASIN=B001D2WUDO" rel="nofollow">Amazon</a>
<span
class="hidden-xs"> | </span>
<a
href="https://geo.itunes.apple.com/us/movie/katt-williams-its-pimpin-pimpin/id303476676?uo=4&at=10l8IA" rel="nofollow">iTunes</a></td></tr><tr><td
class="date">2007</td><td
class="title"><strong>Katt Williams: American Hustle (The Movie)</strong></td><td
class="buylinks">
<strong
class="hidden-xs">Buy </strong>
<a
href="http://www.amazon.com/gp/product/B000VLLYF8?ie=UTF8&amp;tag=comedydb-20&amp;linkCode=as2&amp;camp=1789&amp;creative=9325&amp;creativeASIN=B000VLLYF8" rel="nofollow">Amazon</a>
<span
class="hidden-xs"> | </span>
<a
href="https://geo.itunes.apple.com/us/movie/katt-williams-american-hustle/id620237150?uo=4&at=10l8IA" rel="nofollow">iTunes</a></td></tr><tr><td
class="date">2006</td><td
class="title"><strong>Comic Relief 2006</strong><p
class="note">Benefit show that features multiple comics.<p></td><td
class="buylinks">
<strong
class="hidden-xs">Buy </strong>
<a
href="http://www.amazon.com/gp/product/B0010IOALG?ie=UTF8&amp;tag=comedydb-20&amp;linkCode=as2&amp;camp=1789&amp;creative=9325&amp;creativeASIN=B0010IOALG" rel="nofollow">Amazon</a>
<span
class="hidden-xs"> | </span>
<a
href="https://geo.itunes.apple.com/us/tv-season/comic-relief-the-latest/id282265207?i=282265440&uo=4&at=10l8IA" rel="nofollow">iTunes</a></td></tr><tr><td
class="date">2006</td><td
class="title"><strong>Def Comedy Jam</strong><p
class="note">Season 7<p></td><td
class="buylinks">
<strong
class="hidden-xs">Buy </strong>
<a
href="http://www.amazon.com/gp/product/B000O3C538?ie=UTF8&amp;tag=comedydb-20&amp;linkCode=as2&amp;camp=1789&amp;creative=9325&amp;creativeASIN=B000O3C538" rel="nofollow">Amazon</a></td></tr><tr><td
class="date">2006</td><td
class="title"><strong>Katt Williams: The Pimp Chronicles Part 1</strong></td><td
class="buylinks">
<strong
class="hidden-xs">Buy </strong>
<a
href="http://www.amazon.com/gp/product/B000GRUN40?ie=UTF8&amp;tag=comedydb-20&amp;linkCode=as2&amp;camp=1789&amp;creative=9325&amp;creativeASIN=B000GRUN40" rel="nofollow">Amazon</a>
<span
class="hidden-xs"> | </span>
<a
href="https://geo.itunes.apple.com/us/movie/katt-williams-pimp-chronicles/id290264519?uo=4&at=10l8IA" rel="nofollow">iTunes</a></td></tr><tr><td
class="date">2006</td><td
class="title"><strong>Katt Williams: Live - Let a Playa Play</strong></td><td
class="buylinks">
<strong
class="hidden-xs">Buy </strong>
<a
href="http://www.amazon.com/gp/product/B000G8NXXM?ie=UTF8&amp;tag=comedydb-20&amp;linkCode=as2&amp;camp=1789&amp;creative=9325&amp;creativeASIN=B000G8NXXM" rel="nofollow">Amazon</a>
<span
class="hidden-xs"> | </span>
<a
href="https://geo.itunes.apple.com/us/movie/katt-williams-live/id718699176?at=10l8IA&mt=6" rel="nofollow">iTunes</a></td></tr></table><a
href="#books"><h3 class="work_head">Books <span>(by and about)</span></h3></a><table
class="table table-striped"><tr><td><p
class="none">No books by or about this comedian.</p></td></tr></table></div><div
class="main_videos hidden-xs"><h2 class="secondary_head">Videos</h2>
<div
class="row"><div
class="col-sm-4 vid">
<a
href="http://www.dead-frog.com/comedians/play-video/ZO6Ez7aLMMA" title="Katt Williams   Kattpacalypse Full" data-toggle="modal" data-target="#modal"><img
src="/images/video_placeholder.png" data-src="http://i.ytimg.com/vi/ZO6Ez7aLMMA/mqdefault.jpg" class="jail img-responsive"></a><p>Katt Williams   Kattpacalypse Full</p> <a
href="http://www.dead-frog.com/comedians/play-video/ZO6Ez7aLMMA" title="Katt Williams   Kattpacalypse Full" id="play-video_button" data-toggle="modal" data-target="#modal" class="pull-right btn btn-xs btn-custom">Watch</a></div>
<div
class="col-sm-4 vid">
<a
href="http://www.dead-frog.com/comedians/play-video/MJHTqJRQ-6s" title="Katt Williams Latest 2017 - Katt Williams Stand Up Comedy 2017" data-toggle="modal" data-target="#modal"><img
src="/images/video_placeholder.png" data-src="http://i.ytimg.com/vi/MJHTqJRQ-6s/mqdefault.jpg" class="jail img-responsive"></a><p>Katt Williams Latest 2017 - Katt Williams Stand Up Comedy 2017</p> <a
href="http://www.dead-frog.com/comedians/play-video/MJHTqJRQ-6s" title="Katt Williams Latest 2017 - Katt Williams Stand Up Comedy 2017" id="play-video_button" data-toggle="modal" data-target="#modal" class="pull-right btn btn-xs btn-custom">Watch</a></div>
<div
class="col-sm-4 vid">
<a
href="http://www.dead-frog.com/comedians/play-video/9v3cNAwPTp0" title="Katt Williams in Tallahassee, Florida - "Conspiracy Theory" 2017 Comedy Show" data-toggle="modal" data-target="#modal"><img
src="/images/video_placeholder.png" data-src="http://i.ytimg.com/vi/9v3cNAwPTp0/mqdefault.jpg" class="jail img-responsive"></a><p>Katt Williams in Tallahassee, Florida - "Conspiracy Theory" 2017&hellip;</p> <a
href="http://www.dead-frog.com/comedians/play-video/9v3cNAwPTp0" title="Katt Williams in Tallahassee, Florida - "Conspiracy Theory" 2017 Comedy Show" id="play-video_button" data-toggle="modal" data-target="#modal" class="pull-right btn btn-xs btn-custom">Watch</a></div>
</div><p
class="text-center"><a
href="http://www.dead-frog.com/comedians/video/katt-williams">More Katt Williams Video</a></p></div><div
class="row"><div
class="col-xs-12 col-sm-10 col-sm-offset-1"><h2 class="secondary_head">Biography</h2><p>Katt Williams was born September 2nd in Cincinnati, Ohio. He was raised in Dayton, and when he left home, he voyaged from place to place in order to make a living for himself. Because he was such an intelligent child, he became very inventive in his methods to support himself. This included selling magazines door to door, and pretending to be a comedian at a Florida night club, even though he was under age. The audience was extremely responsive to his natural talent, and he then realized that it was a possibility to make a living performing stand-up comedy.</p><p>In 1995, Katt became a father and his life then changed forever. &#8220;Having no legal skills and having an aversion to manual labor, my options weren&#8217;t that great. I was a single father and I had constant motivation&#8221;. He and his son traveled to a variety of places in order to perform comedy for small amounts of money. Needless to say, this was extremely difficult for a single parent. He has since adopted children, which has also been a source of tireless motivation.</p><p>Katt Williams began to perform in &#8220;White rooms&#8221; all across the country. Although his reputation grew, he had not yet achieved his goals in the comedy realm. In 1999, Katt moved to Los Angeles, California, and within a year and a half, became a respected presence in the local comedy clubs. Performing at places like the Laugh Factory, The Improv, The Comedy Store, and The Icehouse, allowed him to host his own comedy room at the Hollywood Park Casino. In the summer of 2001, he was awarded Cedric the Entertainer&#8217;s Anheiser-Busch &#8220;Best Los Angeles Comic&#8217;s Award.</p><p>In October of 2001, Katt went on his first theatrical audition at New Line Cinema for Friday After Next, and landed the role of &#8220;Money Mike&#8220;, which has contributed to a large portion of his fan base. Since then, Katt has appeared in a variety of television shows, such as The Tracy Morgan Show, My Wife and Kids, NYPD Blue, Cuts, Girlfriends, and is currently on the number one show on MTV, Wild &#8216;N Out with Nick Cannon. He has also provided numerous skits and video appearances for artists such as Ludacris, E-40, Outkast, Lil&#8217; Kim, Lyfe Jennings, Nick Cannon, Suga Free, Lil&#8216; Scrappy, and a variety of other up and coming artists. He is also sponsored by several corporations such as Capri Jewelers (Phoenix, AZ) and T-Mobile (Urban World Wireless). Katt Williams is currently preparing for the release of his new rap/comedy album with Universal Records which is a collaboration with several well known artists. He will also be on his own comedy tour which begins the first part of 2006. He reaches his many fans through myspace.com (katt williams) and kattwilliams.com.</p></div></div><div
class="row"><div
class="col-xs-12"><div
class="comic_linkbox">
Links:&nbsp;&nbsp;
<a
href="http://www.twitter.com/KattPackAllDay"><i
class="fa fa-twitter-square"></i> Twitter</a></div></div></div></div><div
class="modal fade" id="modal" tabindex="-1" role="dialog" aria-labelledby="myModalLabel" aria-hidden="true"><div
class="modal-dialog"><div
class="modal-content"><div
class="modal-header">
<button
type="button" class="close" data-dismiss="modal" aria-label="Close"><span
aria-hidden="true">&times;</span></button><h4 class="modal-title" id="myModalLabel">Modal title</h4></div><div
class="modal-body"></div><div
class="modal-footer">
<button
type="button" class="btn btn-default" data-dismiss="modal">Close</button></div></div></div></div></div><div
class="hidden-xs col-sm-12 col-md-4 sidebar"><div
class="row"><div
class="col-sm-5 col-md-12 spot300x250">
<!-- /74561012/Dead-Frog_Box -->
<div id='div-gpt-ad-1491386249373-1' style='height:250px; width:300px;'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1491386249373-1'); });
</script>
</div></div><div
class="col-sm-5 col-md-12"><div
class="show-search side-show-search"><h2>Find Comedy Near You</h2><h3>Discover stand-up coming to your town</h3><form
id="geofinder_form" method="post" action="http://www.dead-frog.com/"  ><div
class='hiddenFields'>
<input
type="hidden" name="ACT" value="118" />
<input
type="hidden" name="RP" value="/live-comedy/local-show-results" />
<input
type="hidden" name="user_lat" value="" />
<input
type="hidden" name="user_lng" value="" />
<input
type="hidden" name="site_id" value="1" />
<input
type="hidden" name="csrf_token" value="6ea5922661603fdfa6c6b234eef29a0942027ee8" /></div><input
type="hidden" name="csrf_token" value="6ea5922661603fdfa6c6b234eef29a0942027ee8"><div
class="form-group">
<label
class="control-label" for="find">City and state <em>or</em> zip code</label>
<input
type="text" class="form-control input-sm" name="geoquery" id="find"/></div><div
class="form-group">
<label
class="control-label" for="radius">How far will you travel?</label>
<select
class="form-control input-sm" name="radius" id="radius"><option
value="10">10 miles</option><option
value="25" selected="selected">25 miles</option><option
value="50">50 miles</option><option
value="75">75 miles</option><option
value="100">100 miles</option><option
value="200">200 miles</option>
</select></div>
<input
class="btn btn-sm btn-custom" type="submit" value="Find Local Comedy" /></form></div></div><div
class="col-sm-5 col-md-12 fave_five hidden-sm"><h2>The 5 Funniest Comedians</h2><h3>Based on the <a
href="/comedians/whos-funnier">Who's Funnier</a> Game.</h3>
<a
href="/comedians/comic/george-carlin">
<img
src="http://media.dead-frog.com/comics/75x100/george_carlin.jpg?mtime=1332461372" width="75" height="100" alt="George Carlin" class="fave_five_pic"/>
</a><div
class="item">
<span
class="name">1.&nbsp;
<a
href="/comedians/comic/george-carlin">George Carlin</a>
</span></div><div
class="item">
<span
class="name">2.&nbsp;<a
href="/comedians/comic/richard-pryor">Richard Pryor</a></span></div><div
class="item">
<span
class="name">3.&nbsp;<a
href="/comedians/comic/louis-ck">Louis C.K.</a></span></div><div
class="item">
<span
class="name">4.&nbsp;<a
href="/comedians/comic/norm-macdonald">Norm Macdonald</a></span></div><div
class="item">
<span
class="name">5.&nbsp;<a
href="/comedians/comic/mitch-hedberg">Mitch Hedberg</a></span></div><p>
<strong><a
href="/comedians/funniest">See the 25 Funniest Comedians</a></strong><br/>
Influence the rankings by playing <strong><a
href="/comedians/whos-funnier">Who's Funnier</a></strong>.</p></div><div
class="col-sm-2 col-md-12"><div
class="feeds"><h3 class="old_head_style">Subscribe (RSS)</h3><ul
class="list-unstyled"><li><a
href="http://feeds.feedburner.com/dead-frog" rel="alternate" type="application/rss+xml">Blog</a></li><li><a
href="http://feeds.feedburner.com/standupcomedy" rel="alternate" type="application/rss+xml">Comedy Database</a></li></ul></div><div
class="linkbox"><h3 class="old_head_style">Contact</h2><ul
class="list-unstyled"><li
id="facebook" class="linklist"><a
href="http://www.facebook.com/deadfrogcomedyblog">Facebook</a></li><li
id="twitter" class="linklist"><a
href="http://www.twitter.com/deadfrog">Twitter</a></li></ul></div><div
class="hidden-sm sidebar_box"><h3 class="old_head_style">Newly Added Comedians</h3><ul
class="list-unstyled"><li><a
href="/comedians/comic/james-adomian">James Adomian</a></li><li><a
href="/comedians/comic/jamie-kennedy">Jamie Kennedy</a></li><li><a
href="/comedians/comic/jay-pharoah">Jay Pharoah</a></li><li><a
href="/comedians/comic/joe-list">Joe List</a></li><li><a
href="/comedians/comic/tom-cotter">Tom Cotter</a></li><li><a
href="/comedians/comic/hampton-yount">Hampton Yount</a></li><li><a
href="/comedians/comic/michelle-wolf">Michelle Wolf</a></li><li><a
href="/comedians/comic/joey-diaz">Joey Diaz</a></li><li><a
href="/comedians/comic/arsenio-hall">Arsenio Hall</a></li><li><a
href="/comedians/comic/chris-franjola">Chris Franjola</a></li><li><a
href="/comedians/comic/justin-willman">Justin Willman</a></li><li><a
href="/comedians/comic/jeremy-hotz">Jeremy Hotz</a></li><li><a
href="/comedians/comic/tony-rock">Tony Rock</a></li><li><a
href="/comedians/comic/steve-gillespie">Steve Gillespie</a></li><li><a
href="/comedians/comic/jenny-zigrino">Jenny Zigrino</a></li></ul></div></div></div></div></div></div><div
id="footer" class="container-fluid"><p
class="footer_quote">
<em>&ldquo;Analyzing humor is like dissecting a frog. Few people are interested and the frog dies of it.&rdquo;</em>
<span>&#8212;E. B. White</span></p><p
class="site_data"><a
href="http://www.dead-frog.com/site/advertise">Advertise</a> | <a
href="http://www.dead-frog.com/site/privacy">Privacy Policy</a> | Copyright 2004-2017 Todd Jackson</p></div> <script src="https://ajax.googleapis.com/ajax/libs/jquery/1.12.4/jquery.min.js"></script>  <script src="https://maxcdn.bootstrapcdn.com/bootstrap/3.3.7/js/bootstrap.min.js" integrity="sha384-Tc5IQib027qvyjSMfHjOMaLkfuWVxZxUPnCJA7l2mCWNIpG9mGCD8wGNIcPD7Txa" crossorigin="anonymous"></script> <script type="text/javascript" src="http://www.dead-frog.com/minicache/c31d7da006fb1390a4d23823b8baafd138241177.1491459762.js"></script> </body></html>