<!DOCTYPE html><html
lang="en"><head><meta
charset="utf-8"><meta
http-equiv="X-UA-Compatible" content="IE=edge"><meta
name="viewport" content="width=device-width, initial-scale=1"><title>Jerrod Carmichael | Stand-Up Comedy Database | Dead-Frog - A Comedy Blog</title><meta
name="description" content="Profile of stand-up comedian Jerrod Carmichael including complete works, video, biography, jokes, reviews and tour schedule." /><meta
property="og:title" content="Jerrod Carmichael | Stand-Up Comedy Database | Dead-Frog - A Comedy Blog"/><meta
property="og:type" content="actor" /><meta
property="og:url" content="http://www.dead-frog.com/comedians/comic/jerrod-carmichael" /><meta
property="og:image" content="http://media.dead-frog.com/comics/jerrod_carmichael.jpg?mtime=1446327076" /><meta
property="og:locale" content="en_US"><meta
property="og:description" content="Profile of stand-up comedian Jerrod Carmichael including complete works, video, biography, jokes, reviews and tour schedule."><meta property="og:site_name" content="Dead-Frog - A Comedy Blog" />
<meta property="fb:admins" content="649961018" />
<meta property="fb:app_id" content="152881194733416" /><meta
name="twitter:card" content="summary" /><meta
name="twitter:site" content="@deadfrog" /><meta
name="twitter:title" content="Jerrod Carmichael | Stand-Up Comedy Database | Dead-Frog - A Comedy Blog" /><meta
name="twitter:description" content="Profile of stand-up comedian Jerrod Carmichael including complete works, video, biography, jokes, reviews and tour schedule." /><meta
name="twitter:image" content="http://media.dead-frog.com/comics/jerrod_carmichael.jpg?mtime=1446327076" /> <script>(function(d){var config={kitId:'ipw5wcb',scriptTimeout:3000,async:true},h=d.documentElement,t=setTimeout(function(){h.className=h.className.replace(/\bwf-loading\b/g,"")+" wf-inactive";},config.scriptTimeout),tk=d.createElement("script"),f=false,s=d.getElementsByTagName("script")[0],a;h.className+=" wf-loading";tk.src='https://use.typekit.net/'+config.kitId+'.js';tk.async=true;tk.onload=tk.onreadystatechange=function(){a=this.readyState;if(f||a&&a!="complete"&&a!="loaded")return;f=true;clearTimeout(t);try{Typekit.load(config)}catch(e){}};s.parentNode.insertBefore(tk,s)})(document);</script> <link
rel="shortcut icon" href="/favicon.ico" type="image/x-icon" /><link
rel="apple-touch-icon" href="/apple-touch-icon.png" /><link
rel="apple-touch-icon" sizes="57x57" href="/apple-touch-icon-57x57.png" /><link
rel="apple-touch-icon" sizes="72x72" href="/apple-touch-icon-72x72.png" /><link
rel="apple-touch-icon" sizes="114x114" href="/apple-touch-icon-114x114.png" /><link
rel="apple-touch-icon" sizes="144x144" href="/apple-touch-icon-144x144.png" /><link
rel="stylesheet" href="https://maxcdn.bootstrapcdn.com/bootstrap/3.3.7/css/bootstrap.min.css" integrity="sha384-BVYiiSIFeK1dGmJRAkycuHAHRg32OmUcww7on3RYdg4Va+PmSTsz/K68vbdEjh4u" crossorigin="anonymous"> <script src="https://use.fontawesome.com/54005dc295.js"></script> <link
rel="stylesheet" type="text/css" media="all" href="http://www.dead-frog.com/minicache/649ae2ca0fe6a86be7ed94d76d7e01d4d072fcd5.1488577177.css" />
<!--[if lt IE 9]> <script src="https://oss.maxcdn.com/html5shiv/3.7.2/html5shiv.min.js"></script> <script src="https://oss.maxcdn.com/respond/1.4.2/respond.min.js"></script> <![endif]--><link
rel="alternate" type="application/rss+xml" title="RSS feed for Dead-Frog Blog" href="http://feeds.feedburner.com/dead-frog" /><link
rel="alternate" type="application/rss+xml" title="RSS feed for Dead-Frog Stand-Up Comic Database" href="http://feeds.feedburner.com/standupcomedy" /> <script type='text/javascript'>var googletag=googletag||{};googletag.cmd=googletag.cmd||[];(function(){var gads=document.createElement('script');gads.async=true;gads.type='text/javascript';var useSSL='https:'==document.location.protocol;gads.src=(useSSL?'https:':'http:')+'//www.googletagservices.com/tag/js/gpt.js';var node=document.getElementsByTagName('script')[0];node.parentNode.insertBefore(gads,node);})();</script> <script type='text/javascript'>googletag.cmd.push(function(){googletag.defineSlot('/74561012/Dead-Frog_Mobile_Leader',[320,50],'div-gpt-ad-1446583448033-0').addService(googletag.pubads());googletag.defineSlot('/74561012/Dead-Frog_Box',[300,250],'div-gpt-ad-1446583448033-1').addService(googletag.pubads());googletag.defineSlot('/74561012/Dead-Frog_Leader',[728,90],'div-gpt-ad-1446583448033-2').addService(googletag.pubads());googletag.pubads().setCentering(true);googletag.pubads().enableSingleRequest();googletag.enableServices();});</script> <link
rel="canonical" href="http://www.dead-frog.com/comedians/comic/jerrod-carmichael" /><script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-576170-1', {'siteSpeedSampleRate': 100});
  ga('send', 'pageview');

</script></head><body ><div
id="site_top" class="hidden-xs"><div
class="container-fluid"><div
class="row"><div
id="logo" class="col-sm-8">
<a
href="/" title="Dead-Frog Home Page">
<img
src="http://media.dead-frog.com/site/new_logo.png" alt="Dead-Frog - A Comedy Blog" width="520" height="75" border="0" />
</a></div><div
class="col-sm-4"><div
class="new_members"><img
src="http://media.dead-frog.com/site/dead_frog_icon_grey.jpg" alt="default dead-frog avatar" height="50" width="50" class="top_avatar"/><div
class="memberinfo"><h4>Member Functions</h4><ul><li><a
href="http://www.dead-frog.com/audience/login">Log-In</a></li><li><a
href="http://www.dead-frog.com/audience/register">Register</a></li><li><a
href="http://www.dead-frog.com/audience/forgot_password">Forgot Password</a>?</li><ul></div></div></div></div><div
class="topads">
<!-- /74561012/Dead-Frog_Leader -->
<div id='div-gpt-ad-1446583448033-2' style='height:90px; width:728px;'>
<script type='text/javascript'>
googletag.cmd.push(function() {
googletag.display('div-gpt-ad-1446583448033-2'); });
</script>
</div></div></div></div><nav
class="navbar navbar-inverse mynavbar"><div
class="navbar-container container-fluid"><div
class="navbar-header">
<button
type="button" class="navbar-toggle collapsed" data-toggle="collapse" data-target="#bs-example-navbar-collapse-1">
<span
class="sr-only">Toggle navigation</span>
<span
class="icon-bar"></span>
<span
class="icon-bar"></span>
<span
class="icon-bar"></span>
</button>
<a
class="navbar-brand visible-xs-block" href="http://www.dead-frog.com">
<img
alt="Dead-Frog - A Comedy Blog" src="http://media.dead-frog.com/site/mobile_logo.png"  width="200" height="39">
</a></div><div
class="collapse navbar-collapse" id="bs-example-navbar-collapse-1"><ul
class="nav navbar-nav"><li >
<a
href="http://www.dead-frog.com/blog" title="Comedy Blog and Comedy News">blog</a></li><li
class="dropdown active">
<a
href="http://www.dead-frog.com/comedians" class="dropdown-toggle" data-toggle="dropdown" role="button" aria-haspopup="true" aria-expanded="false" title="Stand-Up Comedy Database">comedians <span
class="caret"></span></a><ul
class="dropdown-menu"><li><a
href="http://www.dead-frog.com/comedians/funniest">Funniest</a></li><li><a
href="http://www.dead-frog.com/comedians/favorite">Favorite</a></li><li
role="separator" class="divider"></li><li><a
href="http://www.dead-frog.com/comedians/greatest-living">Greatest Living</a></li><li><a
href="http://www.dead-frog.com/comedians/best">Best Comedians Ever</a></li><li><a
href="http://www.dead-frog.com/comedians/best-material">Best Joke Writers</a></li><li><a
href="http://www.dead-frog.com/comedians/best-delivery">Best Joke Tellers</a></li><li
role="separator" class="divider"></li><li><a
href="http://www.dead-frog.com/comedians/list">All Comedians</a></li></ul></li><li >
<a
href="http://www.dead-frog.com/live-comedy" title="Live Comedy">live comedy</a></li><li >
<a
href="http://www.dead-frog.com/comedy-clubs" title="Comedy Clubs">comedy clubs</a></li><li >
<a
href="http://www.dead-frog.com/comedians/whos-funnier" title="Who&rsquo;s Funnier">who&rsquo;s funnier</a></li><li >
<a
href="http://www.dead-frog.com/charts" title="iTunes Top 100 Comedy Albums">charts</a></li><li >
<a
href="http://www.dead-frog.com/site/about" title="About Dead-Frog and Todd Jackson">about</a></li></ul><form
id="new_top_search" class="navbar-form navbar-right hidden-xs hidden-sm" method="post" action="http://www.dead-frog.com/"  ><div
class='hiddenFields'>
<input
type="hidden" name="ACT" value="25032105" />
<input
type="hidden" name="RES" value="200" />
<input
type="hidden" name="meta" value="mzWR5rp/vLEnoGhgsDwNhp3UvapFFpivsFH0CTLWqnuEiQ5/873Q9eUL8MccJU7/EaFDhJE3oLy3Y6wipxxXPTdR8stGi589ow9oHliV1E1Rl1cOagHqJkVspU8k9r9mr5guUsTbYeEj2Ztrw3lCrKhVzizeqvVUkUns+2WfLOBVCYLppmXV9xDmzzOE1Q32asD+DtGTQmrpJKWSUg25HF1fBl/L559DQoQbICwYkgmDd+131TrsAn5XQLVOC076AF+h5oCWJeQQopYj+1i6s7fdkPrpv27QbmE2660T+aIKHYyjNgxIiXYw1seVbMsoVZ8eaKtjl0ro2QK+TWZwDHjQQMgNmdgpuLDDoBhRJLctfRWdIECzCTHiIy/ft8eA" />
<input
type="hidden" name="site_id" value="1" />
<input
type="hidden" name="csrf_token" value="215c3e446d02782ed19ee7f77865a13cdea1d8f0" /></div><div
class="form-group">
<input
type="text" name="keywords" id="keywords" value="" class="form-control" placeholder="Search" /></div>
<button
type="submit" class="btn btn-custom"/>
<span
class="glyphicon glyphicon-search" aria-hidden="true"></span>
</button></form></div></div>
</nav><div
class="container-fluid main_container"><div
class="row visible-xs-block"><div
class="col-xs-12 no-gutter"><div
id='div-gpt-ad-1446583448033-0' style='height:50px; width:320px;'> <script type='text/javascript'>googletag.cmd.push(function(){googletag.display('div-gpt-ad-1446583448033-0');});</script> </div></div></div><div
class="row"><div
class="col-xs-12"></div><div
class="col-xs-12 col-md-8 center-stage" >
<header
class="comic_innernav"><div
class="row"><div
class="col-xs-12 col-sm-7">
<a
href="http://www.dead-frog.com/comedians"><h2>Stand-Up Comedy Database</h2></a></div><div
class="innernav_section col-xs-12 col-sm-5"><form
id="comic_innernav_search" method="post" action="http://www.dead-frog.com/"  ><div
class='hiddenFields'>
<input
type="hidden" name="ACT" value="25032105" />
<input
type="hidden" name="RES" value="" />
<input
type="hidden" name="meta" value="mzWR5rp/vLEnoGhgsDwNhp3UvapFFpivsFH0CTLWqns6syJdumj0qeDaM0T0+5R0PBBWSdnSGhA471vKA9B8daH45kQp5gt6SAWaUfoGeU8Vjzozj4XFRI7+gSZFlfIOEWa/grBH/xCryb60/N8zMepUg62q3XTjSP9NkbPfSBHzc4Lj0tEAAQAdC6JpCwbSl78fl4b4sTShcHyodNy1j1HLuMzLf3FtUwUNsBXdJiW83GQkoSlDAgKdsaeGlJUThAqnLX2QmqDPD1bXUG8y7OEJWyn7fIUjXbOyhBt+FN8rC24ygllhTl9Pj2SUnrUx8DSGi/vbt0FQVybElfhhjgB8a0gP+HRY4z/1AkMNQUWCLUzH/JxOK2sqv+EEXS4W" />
<input
type="hidden" name="site_id" value="1" />
<input
type="hidden" name="csrf_token" value="215c3e446d02782ed19ee7f77865a13cdea1d8f0" /></div><div
class="input-group input-group-sm">
<input
type="text" name="keywords" id="comickeywords" placeholder="Find a Comic" value="" class="form-control" size="18" maxlength="50" />
<span
class="input-group-btn">
<button
class="btn btn-default btn-custom" type="submit"/><span
class="glyphicon glyphicon-search" aria-hidden="true"></span></button>
</span></div></form></div></div>
</header><div
class="row profile_head_row"><div
class="col-xs-12"><div
class="media main_profile_top"><div
class="media-left">
<img
src="http://media.dead-frog.com/comics/jerrod_carmichael.jpg?mtime=1446327076" width="113" height="150" class="main_image" alt="Stand-Up Comedian Jerrod Carmichael"/></div><div
class="media-body"><h1 id="page_head">Jerrod Carmichael</h1><div
class="vitals">
<strong>Born:</strong> 1988<br/>
<strong>Blue Meter:</strong> Tame<br/></div></div></div></div></div><div
class="row"><div
class="col-xs-12 no-gutter"><ul
id="comic_profile_nav" class="nav nav-tabs"><li
role="presentation" class="active"><a
href="#">Main</a></li><li
role="presentation"><a
href="/comedians/jokes/jerrod-carmichael">Jokes</a></li><li
role="presentation"><a
href="http://www.dead-frog.com/comedians/reviews/jerrod-carmichael">Reviews</a></li><li
role="presentation"><a
href="http://www.dead-frog.com/comedians/video/jerrod-carmichael">Video</a></li><li
role="presentation"><a
href="http://www.dead-frog.com/comedians/tour-dates/jerrod-carmichael"><span
class="hidden-xs">Tour Dates</span><span
class="visible-xs-block">Live</span></a></li></ul></div></div><div
class="comic_content"><div
class="row"><div
class="col-xs-12 col-sm-5"><div
class="favenum fave_70368 faveprofile" >
1
<span>Faves</span></div><div
class="fave_comic"><p>Like this comedian?<br/><a
href="http://www.dead-frog.com/audience/login">Log-In</a> or <a
href="http://www.dead-frog.com/audience/register">Register</a> to mark it!</p></div></div><div
class="col-xs-12 col-sm-7"><div
class="wf_box"><h3 class="wf_head"><a
href="/comedians/whos-funnier">Who's Funnier</a></h3>
<span
class="wf_percentage">42.3%</span>
<span
class="wf_record">
<strong>Won:</strong> 110<br/><strong>Lost:</strong> 150
</span></div></div></div><div
id="shows"><h2 class="secondary_head">Next Tour Date</h2><p
class="text-center">Sorry no tour dates are currently scheduled for this comedian.</p></div><div
class="works"><h2 class="secondary_head">Works</h2><a
href="#records"><h3 class="work_head">Records</h3></a><table
class="table table-striped"><tr><td><p
class="none">No records by this comedian.</p></td></tr></table><a
href="#specials"><h3 class="work_head">Specials <span>(and other video)</span></h3></a><table
class="table table-striped"><tr><td
class="date">2017</td><td
class="title"><strong>Jerrod Carmichael: 8</strong></td><td
class="buylinks"></td></tr><tr><td
class="date">2014</td><td
class="title"><strong>Jerrod Carmichael: Love at the Store</strong><p
class="note">Directed by Spike Lee<p></td><td
class="buylinks"></td></tr><tr><td
class="date">2013</td><td
class="title"><strong>Funny as Hell (Season 3)</strong><p
class="note">Featured Multiple Comedians. Aired on HBO Canada.<p></td><td
class="buylinks"></td></tr></table><a
href="#books"><h3 class="work_head">Books <span>(by and about)</span></h3></a><table
class="table table-striped"><tr><td><p
class="none">No books by or about this comedian.</p></td></tr></table></div><div
class="main_videos hidden-xs"><h2 class="secondary_head">Videos</h2>
<div
class="row"><div
class="col-sm-4 vid">
<a
href="http://www.dead-frog.com/comedians/play-video/WWV9tJgfzsw" title="Jerrod Carmichael - Bernie, Hill, Trump (Stand-up Comedy)" data-toggle="modal" data-target="#modal"><img
src="http://i.ytimg.com/vi/WWV9tJgfzsw/mqdefault.jpg" class="img-responsive"></a><p>Jerrod Carmichael - Bernie, Hill, Trump (Stand-up Comedy)</p> <a
href="http://www.dead-frog.com/comedians/play-video/WWV9tJgfzsw" title="Jerrod Carmichael - Bernie, Hill, Trump (Stand-up Comedy)" id="play-video_button" data-toggle="modal" data-target="#modal" class="pull-right btn btn-xs btn-custom">Watch</a></div>
<div
class="col-sm-4 vid">
<a
href="http://www.dead-frog.com/comedians/play-video/CqtAeQx1Qno" title="Jerrod Carmichael: 8 | HBO Comedy Special Official Promo" data-toggle="modal" data-target="#modal"><img
src="http://i.ytimg.com/vi/CqtAeQx1Qno/mqdefault.jpg" class="img-responsive"></a><p>Jerrod Carmichael: 8 | HBO Comedy Special Official Promo</p> <a
href="http://www.dead-frog.com/comedians/play-video/CqtAeQx1Qno" title="Jerrod Carmichael: 8 | HBO Comedy Special Official Promo" id="play-video_button" data-toggle="modal" data-target="#modal" class="pull-right btn btn-xs btn-custom">Watch</a></div>
<div
class="col-sm-4 vid">
<a
href="http://www.dead-frog.com/comedians/play-video/5B0lkdO3DSU" title="Jerrod Carmichael   Love Test lft on Vimeo" data-toggle="modal" data-target="#modal"><img
src="http://i.ytimg.com/vi/5B0lkdO3DSU/mqdefault.jpg" class="img-responsive"></a><p>Jerrod Carmichael   Love Test lft on Vimeo</p> <a
href="http://www.dead-frog.com/comedians/play-video/5B0lkdO3DSU" title="Jerrod Carmichael   Love Test lft on Vimeo" id="play-video_button" data-toggle="modal" data-target="#modal" class="pull-right btn btn-xs btn-custom">Watch</a></div>
</div><p
class="text-center"><a
href="http://www.dead-frog.com/comedians/video/jerrod-carmichael">More Jerrod Carmichael Video</a></p></div><div
class="row"><div
class="col-xs-12 col-sm-10 col-sm-offset-1"><h2 class="secondary_head">Biography</h2><p>Jerrod Carmichael is an LA based standup and performer originally from Winston-Salem, North Carolina. He was featured last year in Variety as being one of the top ten comics to watch, as well as being one of the New Faces at the Montreal Just For Laughs Festival. He recurred on Fox’s The Goodwin Games and can be seen in Universal’s upcoming feature Townies. Jerrod is currently working on an untitled comedy pilot for NBC that he wrote and will star in and produce.</p><p>Jerrod is a regular around some of LA’s favorite standup shows, including Meltdown, The Improv, Laugh Factory and many alternative rooms.</p></div></div><div
class="row"><div
class="col-xs-12"><div
class="comic_linkbox">
Links:&nbsp;&nbsp;
<a
href="http://www.facebook.com/JerrodCarmichael"><i
class="fa fa-facebook-official"></i> Facebook</a>&nbsp;&nbsp;
<a
href="http://www.twitter.com/NotoriousROD"><i
class="fa fa-twitter-square"></i> Twitter</a></div></div></div></div><div
class="modal fade" id="modal" tabindex="-1" role="dialog" aria-labelledby="myModalLabel" aria-hidden="true"><div
class="modal-dialog"><div
class="modal-content"><div
class="modal-header">
<button
type="button" class="close" data-dismiss="modal" aria-label="Close"><span
aria-hidden="true">&times;</span></button><h4 class="modal-title" id="myModalLabel">Modal title</h4></div><div
class="modal-body"></div><div
class="modal-footer">
<button
type="button" class="btn btn-default" data-dismiss="modal">Close</button></div></div></div></div></div><div
class="hidden-xs col-sm-12 col-md-4 sidebar"><div
class="row"><div
class="col-sm-5 col-md-12 spot300x250">
<!-- /74561012/Dead-Frog_Box -->
<div id='div-gpt-ad-1446583448033-1' style='height:250px; width:300px;'>
<script type='text/javascript'>
googletag.cmd.push(function() {
googletag.display('div-gpt-ad-1446583448033-1'); });
</script>
</div></div><div
class="col-sm-5 col-md-12"><div
class="show-search side-show-search"><h2>Find Comedy Near You</h2><h3>Discover stand-up coming to your town</h3><form
id="geofinder_form" method="post" action="http://www.dead-frog.com/"  ><div
class='hiddenFields'>
<input
type="hidden" name="ACT" value="118" />
<input
type="hidden" name="RP" value="/live-comedy/local-show-results" />
<input
type="hidden" name="user_lat" value="" />
<input
type="hidden" name="user_lng" value="" />
<input
type="hidden" name="site_id" value="1" />
<input
type="hidden" name="csrf_token" value="215c3e446d02782ed19ee7f77865a13cdea1d8f0" /></div><input
type="hidden" name="csrf_token" value="215c3e446d02782ed19ee7f77865a13cdea1d8f0"><div
class="form-group">
<label
class="control-label" for="find">City and state <em>or</em> zip code</label>
<input
type="text" class="form-control input-sm" name="geoquery" id="find"/></div><div
class="form-group">
<label
class="control-label" for="radius">How far will you travel?</label>
<select
class="form-control input-sm" name="radius" id="radius"><option
value="10">10 miles</option><option
value="25" selected="selected">25 miles</option><option
value="50">50 miles</option><option
value="75">75 miles</option><option
value="100">100 miles</option><option
value="200">200 miles</option>
</select></div>
<input
class="btn btn-sm btn-custom" type="submit" value="Find Local Comedy" /></form></div></div><div
class="col-sm-5 col-md-12 fave_five hidden-sm"><h2>The 5 Funniest Comedians</h2><h3>Based on the <a
href="/comedians/whos-funnier">Who's Funnier</a> Game.</h3>
<a
href="/comedians/comic/george-carlin">
<img
src="http://media.dead-frog.com/comics/75x100/george_carlin.jpg?mtime=1332461372" width="75" height="100" alt="George Carlin" class="fave_five_pic"/>
</a><div
class="item">
<span
class="name">1.&nbsp;
<a
href="/comedians/comic/george-carlin">George Carlin</a>
</span></div><div
class="item">
<span
class="name">2.&nbsp;<a
href="/comedians/comic/richard-pryor">Richard Pryor</a></span></div><div
class="item">
<span
class="name">3.&nbsp;<a
href="/comedians/comic/louis-ck">Louis C.K.</a></span></div><div
class="item">
<span
class="name">4.&nbsp;<a
href="/comedians/comic/norm-macdonald">Norm Macdonald</a></span></div><div
class="item">
<span
class="name">5.&nbsp;<a
href="/comedians/comic/mitch-hedberg">Mitch Hedberg</a></span></div><p>
<strong><a
href="/comedians/funniest">See the 25 Funniest Comedians</a></strong><br/>
Influence the rankings by playing <strong><a
href="/comedians/whos-funnier">Who's Funnier</a></strong>.</p></div><div
class="col-sm-2 col-md-12"><div
id="side_160" class="hidden-sm">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- newfrog_160x600 -->
<ins class="adsbygoogle"
     style="display:inline-block;width:160px;height:600px"
     data-ad-client="ca-pub-8649125013813736"
     data-ad-slot="4832121148"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div><div
class="side_125"><div
class="feeds"><h3 class="old_head_style">Subscribe (RSS)</h3><ul
class="list-unstyled"><li><a
href="http://feeds.feedburner.com/dead-frog" rel="alternate" type="application/rss+xml">Blog</a></li><li><a
href="http://feeds.feedburner.com/standupcomedy" rel="alternate" type="application/rss+xml">Comedy Database</a></li></ul></div><div
class="linkbox"><h3 class="old_head_style">Contact</h2><ul
class="list-unstyled"><li
id="facebook" class="linklist"><a
href="http://www.facebook.com/deadfrogcomedyblog">Facebook</a></li><li
id="twitter" class="linklist"><a
href="http://www.twitter.com/deadfrog">Twitter</a></li></ul></div><div
class="hidden-sm sidebar_box"><h3 class="old_head_style">Newly Added Comedians</h3><ul
class="list-unstyled"><li><a
href="/comedians/comic/joey-diaz">Joey Diaz</a></li><li><a
href="/comedians/comic/hasan-minhaj">Hasan Minhaj</a></li><li><a
href="/comedians/comic/chris-distefano">Chris Distefano</a></li><li><a
href="/comedians/comic/andrew-santino">Andrew Santino</a></li><li><a
href="/comedians/comic/maronzio-vance">Maronzio Vance</a></li><li><a
href="/comedians/comic/carmen-lynch">Carmen Lynch</a></li><li><a
href="/comedians/comic/rory-scovel">Rory Scovel</a></li><li><a
href="/comedians/comic/brent-weinbach">Brent Weinbach</a></li><li><a
href="/comedians/comic/tony-roberts">Tony Roberts</a></li><li><a
href="/comedians/comic/erik-griffin">Erik Griffin</a></li><li><a
href="/comedians/comic/chad-daniels">Chad Daniels</a></li><li><a
href="/comedians/comic/bobby-lee">Bobby Lee</a></li><li><a
href="/comedians/comic/dan-naturman">Dan Naturman</a></li><li><a
href="/comedians/comic/tone-bell">Tone Bell</a></li><li><a
href="/comedians/comic/eddie-ifft">Eddie Ifft</a></li></ul></div></div></div></div></div></div></div><div
id="footer" class="container-fluid"><p
class="footer_quote">
<em>&ldquo;Analyzing humor is like dissecting a frog. Few people are interested and the frog dies of it.&rdquo;</em>
<span>&#8212;E. B. White</span></p><p
class="site_data"><a
href="http://www.dead-frog.com/site/advertise">Advertise</a> | <a
href="http://www.dead-frog.com/site/privacy">Privacy Policy</a> | Copyright 2004-2017 Todd Jackson</p></div> <script src="https://ajax.googleapis.com/ajax/libs/jquery/1.12.4/jquery.min.js"></script>  <script src="https://maxcdn.bootstrapcdn.com/bootstrap/3.3.7/js/bootstrap.min.js" integrity="sha384-Tc5IQib027qvyjSMfHjOMaLkfuWVxZxUPnCJA7l2mCWNIpG9mGCD8wGNIcPD7Txa" crossorigin="anonymous"></script>  <script type="text/javascript" src="//cdn.jsdelivr.net/jquery.slick/1.6.0/slick.min.js"></script> <script type="text/javascript" src="http://www.dead-frog.com/minicache/0f1aa900230e61eff5e8e3e5e5f3c169c414715d.1462567126.js"></script> <!-- Quantcast Tag -->
<script type="text/javascript">
var _qevents = _qevents || [];

(function() {
var elem = document.createElement('script');
elem.src = (document.location.protocol == "https:" ? "https://secure" : "http://edge") + ".quantserve.com/quant.js";
elem.async = true;
elem.type = "text/javascript";
var scpt = document.getElementsByTagName('script')[0];
scpt.parentNode.insertBefore(elem, scpt);
})();

_qevents.push([{
qacct:"p-eciDx4HjQhLNY"
}]);
</script>

<noscript>
<div style="display:none;">
	<img src="//pixel.quantserve.com/pixel/p-eciDx4HjQhLNY.gif" border="0" height="1" width="1" alt="Quantcast"/>
</div>
</noscript>
<!-- End Quantcast tag --></body></html>